Speed Control Error on LifeFitness 9100 Treadmill

Probable Cause

  1. The power source is faulty.
  2. Poor cable connections at the motor controller.
  3. The motor controller is faulty.
  4. CPU control board is faulty.
  5. The drive motor is faulty.

Corrective Action

  1. Ensure treadmill power is a dedicated circuit.
    1. Verify by turning the breaker at the panel OFF.
    2. Using a voltmeter, check for voltage at the treadmill's outlet.
    3. With the breaker at the panel OFF, zero volts should be detected from the outlet treadmill connects.
      1. If voltage is present, the treadmill is not on a dedicated circuit.
      2. Call an electrician to rectify.
  2. Inspect all cable connections to the motor controller. Reset any connections if necessary.
    1. Access Speed Automatic in diagnostics by pressing 9, 1, 9, ENTER and making sure all program keys are OFF.
    2. The TOTAL CAL and CAL/HR LEDs should be lit, if not inspect all wire connections to the motor controller and control board. Reset any connections if necessary.
    3. If the TOTAL CAL LED is lit but the CAL/HR LED is out, then with your feet off the running belt and on the side rails, press the SPEED UP key.
      1. The TOTAL CAL LED should go out initially while the CAL/HR LED comes on.
      2. Once the belt reaches the target speed, both LEDs should be on.
        1. If this is true, both the control board and the motor controller are functioning, complete the speed performance evaluation.
  3. Test unit with a known good motor controller. Replace the motor controller if necessary.
  4. Test unit with a known good CPU control board. Replace CPU control board if necessary.
  5. Inspect drive motor and drive belt. Replace either part if necessary.
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