Keys on Display Console Not Responding, LifeFitness 93C, 93Ci and 93CW Bikes

Probable Cause

  1. Attempting to enter program not available.
  2. Malfunctioning Keypad.
  3. Malfunctioning Display Console

Corrective Action

  1. Refer to Operation Manual for program availability.
  2. Test Keypad in Diagnostics.
    1. Access Diagnostics by holding down the UP ARROW, then pressing the CLEAR key twice.
    2. Then press and hold COOL DOWN and then press ENTER for entry into the TEST/SERVICE MENU.
  3. Test with substitute Display Console.
    1. Replace malfunctioning Display Console.
Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.

Articles in this section

See more
Customer Service Hours:
8:00am - 5:00pm CST Monday to Friday