LifeFitness 9000 Treadmill Speed Control Error

Probable Cause

  1. Insufficient power source.
  2. Poor cable connections at the motor controller.
  3. The motor controller is faulty.
  4. CPU control board is faulty.
  5. Poor connection of the drive motor wiring
  6. The drive belt is loose.
  7. Drive motor housing has a broken weld.

Corrective Action

  1. Ensure treadmill is connected to a dedicated 120V, 20 Amp circuit.
  2. Inspect all cable connections to the motor controller. Reset any connections if necessary.
    1. Access the speed automatic diagnostics by pressing 9, 1, 9, ENTER and making sure all program keys are OFF.
    2. The TOTAL CAL and CAL/HR LEDs should be lit, if not inspect all wire connections to the motor controller and control board. Reset any connections if necessary.
    3. If the TOTAL CAL LED is lit but the CAL/HR LED is out, then with your feet off the running belt and on the side rails, press the SPEED UP key. The TOTAL CAL LED should go out initially while the CAL/HR LED comes on. Once the belt reaches the target speed, both LEDs should be on.
      1. If this is true, both the control board and the motor controller are functioning.
    4. Walk on the unit for 5 minutes. Watch the TOTAL CAL and CAL/HR LEDs.
      1. If the TOTAL CAL LED flashes on and off, the running belt needs to be changed and the deck needs flipped or replaced due to wear on the belt or deck.
  3. Test unit with a known good motor controller and replace if necessary.
  4. Test unit with a known good CPU controller and replace if necessary.
  5. Inspect the drive motor wiring for damage or poor connections. Repair any damaged wiring and reset any poor connections if necessary.
  6. Check the drive motor belt tension. Re-tension drive motor belt if necessary.
  7. Inspect the condition of the drive motor housing and tensioning bolt. Replace if necessary.
Was this article helpful?
0 out of 0 found this helpful

Comments

1 comment
Date Votes
  • Hello, I have a problem with my TR 9000 treadmill, the message "waxer maintenance refill" is appearing, I have already changed the lubrication refill, but the fault has not disappeared and the treadmill does not turn on, could anyone help me solve this problem?

    0

Please sign in to leave a comment.

Articles in this section

See more
Customer Service Hours:
8:00am - 5:00pm CST Monday to Friday